Metamask rpc error: execution reverted

i just tested it with a wallet that has enough eth, but still did not work the second time, but its working multiple times on smart chain network, why is this?

it is still something that I don’t understand, there has to be something related to the steps that are made, there is no reason to not work another time

Please can you show me a sample approval function code with the params, so I could use… please

You should already have one if you say that it worked once. You need the contract address, the abi, the right wallet address and chain selected in MetaMask, the right amount, the right function name to be called.

It’s working fine on other networks, just ethereum main network is giving this issue

You get that error before making the transaction and you end up not making the transaction or you also made the transaction on chain?

I get it before making the transaction

What would be different on ethereum network?

I wished I knew, please what could be different?

With all this, I still haven’t gotten any solution to what’s is causing this…
Why can I sign contra t calls on smart chain, polygon matic and other networks more times, but can’t sign contract calls more times on ethereum network?.. please help, please

What contract functions are you calling on each chain and which contracts on each chain? Or is it the same function and same code?

Thanks for replying, Usdt approve function…
Yea, same function same code

So the same USDT contract (more or less) on each of those chains? Try using another RPC URL for Ethereum in your wallet.

Please I don’t understand?

You can change the RPC or network URL for a chain (Ethereum) in your MetaMask network settings.

I’m trying it now, thanks

It’s still not sending any contract call

What is the Ethereum contract address you’re using? And what is your approve code?

const { runContractFunction: approve, data: enterTxResponse, error, isLoading, isFetching } = useWeb3Contract({

    // chain: "eth",

    contractAddress: "0xdAC17F958D2ee523a2206206994597C13D831ec7",

    abi: ABI,

    functionName: "approve",

    params: {

      _spender: "0xc....",

      _value: 1,

    },

}

);

contractAdrress:“0xdAC17F958D2ee523a2206206994597C13D831ec7”

USDT contract is what i’m using