Ethereum Boilerplate Questions

Hi everyone,

I am new to this amazing community. A few weeks ago I was testing the Ethereum-boilerplate and It was working fine for me. Yesterday, and after the new update, I start have issuing deploying the new git on

I have too many warnings and errors completing the deployment.

Here is my log!
Treating warnings as errors because process.env.CI = true.
Failed to compile.
Module not found: Can’t resolve ‘contracts/contractInfo.json’ in ‘/vercel/path0/src/components/Contract’
Error: Command “react-scripts build” exited with 1

I am not really sure, how I can generate another contracts/contractInfo.json

I was not able to fix this issue. Any luck from your end?

Hi @jphoto

Basic ethereum-boilerplate doesn’t have this functionality, it’s in the NFT marketplace boilerplate. Take a look at

Hi @Cedro

For now, you need to enable deploy functionality even with warning messages(normal practice). There is a detailed guide:

The previous version had no warnings, but this one has them. We will disable them in the coming version

i faced this error each time i use yarn start

C:\Users\USER\Desktop\NFTDevelopment\NFT> yarn start
yarn run v1.22.17
warning package.json: No license field
error Command "start" not found.
info Visit for documentation about this command.

Hi @Cyberhot

Looks like you are running it from the not correct folder. Write cd .. and try again

Hi Yomoo,

I was able to fix this by uploading my contract [contractInfo.json] to the repo before deploying. Now it’s working just fine. Was that right?

it’s also a possible solution. Because the component checks if contractInfo.json exists

Hmm, I guess it’s better to add a blank contractInfo.json to the boilerplate. Thank you @Cedro for the idea.


  1. blank contractInfo.json didn’t work for me. I had to deploy a new contract and upload the new contractInfo.json to this directory */ethereum-boilerplate/src/contracts/contractInfo.json.

  2. Add [ CI=false npm run build] in the build command.

  3. Yarn install.

Now its working just fine.

1 Like

it works now but i saw this warning message in my terminal

Module not found: Can't resolve 'contracts/contractInfo.json' in 'C:\Users\USER\Desktop\NFTDevelopment\NFT\ethereum-boilerplate\src\components\Contract'

  Line 47:70:  'web3' is assigned a value but never used  no-unused-vars

Search for the keywords to learn more about each warning.
To ignore, add // eslint-disable-next-line to the line before.

also when i run yarn start i can see the NFT section is blank

So you guys are great! I have this working fine on my local machine.
Now I’m trying to run it on a linux server. Is there anything obvious I need to change?
Thank you!

This was fixed on the new version

Hey @m360ai

Nice to hear this! This is a frontend, why do you want to run it on a linux server? Sorry, I’m not sure if I got your question correctly. Could you please provide some more info :raised_hands:

How would I change the number of columns on the NFTBalance display to 3 across rather than 4?

Hi @unlabeled

Since our boilerplate was built using Ant design you can find all settings there

Check the pagination and size

where can i get the new version?

Hi. I had a project working fine until for some reason it started showing Web3Api not initialized, run Moralis.start() first. I modified the index.js to look like the newer one on GitHub but then it started showing useMoralisDapp must be used within a MoralisDappProvider on nearly any component.

1 Like

how do i get the fixed new version? @cryptokid @Yomoo